There is a bug with Snipe-IT version 6.0.1 which stops the app from syncing accessories.
You can fix this issue by upgrading your Snipe-IT version to at least 6.0.2.